Database connectivity issue
Incident Report for voucherify
Resolved
After few hours of monitoring, we confirm that the issue has been solved.

We sincerely apologize for any inconvenience caused by this issue and appreciate your understanding in this matter.
Posted Dec 28, 2019 - 14:03 CET
Monitoring
We have released a fix for solving the issue related to the database outage. Additionally, we have introduced a performance improvement to query, which returns a combined data of coupons assigned to a customer object.

We are monitoring the current usage and state of the EU1 cluster.
Posted Dec 28, 2019 - 01:15 CET
Identified
We have introduced a fix for solving the issue related to one of the database nodes. However, the performance might be still degraded. We noticed that one of the typical requests to a database is no optimal. We are working on providing improvement for that unoptimised query.
Posted Dec 27, 2019 - 23:50 CET
Investigating
Some customers are seeing intermittent error messages throughout their account. We’re aware of the issue and are working on it urgently. Incoming requests are only partially being safely received.

We’re really sorry to be holding you up today! Please know our engineering and operations teams are working hard to get everything up and running and we will update you right here in 15 minutes with the latest information.
Posted Dec 27, 2019 - 23:13 CET
This incident affected: Cluster EU1 (Ireland) (EU1 - API, EU1 - Dashboard).