Search API - degraded performance
Incident Report for voucherify
Resolved
This incident has been resolved. We muted segments that use "contains" condition which was affecting our search API. Now we are working on the long-run solution which should replace inefficient search queries using "contains" condition.
Posted Jul 06, 2020 - 19:27 CEST
Monitoring
A fix has been applied and Voucherify Team is monitoring the platform.
Posted Jul 06, 2020 - 13:01 CEST
Investigating
Communication with API is currently being impacted by the anomalous behavior of one of our clusters - AS1. W are investigating the issue. The affected API methods are related to filtering customers and validation rules based on customer segmentation.

The issue occurs only for tenants whos projects are hosted on AS1.
Posted Jul 06, 2020 - 12:40 CEST
This incident affected: Cluster EU1 (Ireland) (EU1 - API, EU1 - Dashboard).