DNS failure - dashboard cannot be accessed
Incident Report for voucherify
Resolved
This incident has been resolved.
Posted over 2 years ago. Mar 02, 2017 - 20:09 CET
Investigating
We are currently investigating this issue.
Posted over 2 years ago. Mar 02, 2017 - 14:00 CET