We continue to monitor for any further issues. So far the impact on us1 cluster was very limited: increased API response latency for 50 minutes (mostly p95 and p99 longtail), between 2026-05-07 23:36 and 2026-05-08 00:48 UTC
Posted May 08, 2026 - 05:21 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 08, 2026 - 04:51 CEST
Investigating
We observe increased error rate and API response times at voucherify caused by an operational issue of our cloud provider in N. Virginia. We are currently investigating the issue.
Posted May 08, 2026 - 03:18 CEST
This incident affected: Cluster US1 (N. Virginia) (US1 - API, US1 - Dashboard).